Знаходження коренів рівняння методом поділу відрізка пополам (реферат)

Реферат на тему:

Знаходження коренів рівняння методом поділу відрізка пополам

Гарною вправою по роботі з MS Excel є програмування на робочому листі
алгоритму пошуку кореня рівняння  F(x) = 0   методом поділу відрізка
навпіл. Нехай неперервна функція F(x) має значення різних знаків на
кінцях відрізка [а; Ь], тобто

F(a)F(b) < 0. Тоді рівняння F(x) = 0 має корінь всередині цього відрізка. Відрізок [а; Ь] називається відрізком локалізації кореня. Нехай с = (а + Ь) / 2 — середина відрізка [а; Ь]. Якщо F(a)F(c) < 0 , то корінь знаходиться на відрізку [а; сз], який беремо за новий відрізок локалізації кореня. Якщо F(a)F(c) > 0 , то за
новий відрізок локалізації кореня беремо [сз; Ь]. Відзначимо, що новий
відрізок локалізації кореня в два рази менший первісного. Процес
розподілу відрізка для локалізації кореня продовжуємо доти, поки його
довжина не стане менше ?, точності знаходження кореня. У цьому випадку
будь-яка точка відрізка локалізації відрізняється від кореня не більше
ніж на ? /2.

На рис. 3.20 приведені результати знаходження кореня з точністю до 0,001
методом поділу відрізка навпіл рівняння х2 — 2 = 0 . За первісний
відрізок локалізації кореня обраний інтервал [0; 2].

Для реалізації цього методу введіть в чарунки робочого листа формули або
значення (табл. 3.2).

Таблиця 3.2 — Формули для знаходження коренів рівняння

Чарунка Формула чи значення

В1 0.001

A3 0

B3 2

C3 =(A3+B3)/2

D3 =(A3^2-2)*(C3^2-2)

E3 =C3^2-2

F3 =ЕСЛИ(В3-А3<$B$1;”Корінь знайдено і рівний   ” &ТЕКСТ(С3;”0.0000”);” ”) А4 =ЕСЛИ (D3<=0;A3;C3) B4 =ЕСЛИ (D3<=0;C3;B3) C4 =(A4+B4)2 D4 =(A4^2-2)*(C4^2-2) E4 =C4^2-2 F4 =ЕСЛИ(В4-А4<$B$1;”Корінь знайдено і рівний   ” &ТЕКСТ(С3;”0.0000”);” ”) Насправді в діапазон C4 : F4 не потрібно вводити формули з клавіатури. Просто виберіть діапазон СЗ : F3, розташуєте покажчик миші на маркері заповнення і пробуксируйте його на один рядок нижче. Рис. 3.20 - Знаходження кореня рівняння методом поділу відрізка навпіл Тепер залишилося тільки вибрати діапазон A4:F4, розташувати покажчик миші на маркері його заповнення і пробуксирувати його вниз доти, поки в стовпці f не з'явиться повідомлення про те, що корінь знайдений. У даному випадку повідомлення з'явиться в чарунці F14, а значення кореня з точністю до 0.001 дорівнює 1.414. На закінчення відзначимо, що в розглянутому прикладі використовувалися: 6 D ¤ E i ue j | e ue f x ? th ?- Операція конкатенації рядків, що поєднує кілька рядків в один. Операція конкатенація позначається символом амперсанда &. При об'єднанні двох рядків другий рядок додається безпосередньо в кінець першої. Результатом є рядок більшого розміру, що містить цілком обидва вихідні рядки. Наприклад, "Andrey " & "Garnaev" дорівнює одному рядку "Andrey Garnaev". Зверніть увагу, що пропуск наприкінці першого рядка використовується для того, щоб у результуючому рядку відокремити перше слово від другого. Замість символу конкатенації можна також використовувати функцію СЧЕПИТЬ (concatenate). Той же самий результат дає формула            = СЧЕПИТЬ ("Andrey ";"Garnaev"). Якщо значення Andrey введене в чарунку А1, а значення Garnaev — в чарунку В2, то той же результат отримаєте використовуючи формулу = СЧЕПИТЬ (А1;" ",B1) чи =A1 & " " & B1. - Функція робочого листа з категорії функцій по роботі з текстом текст (text). Дана функція перетворює значення в текст у заданому числовому форматі. Синтаксис функції текст: ТЕКСТ(значення; форма т)  значення — або числове значення, або формула, обчислення якої дає числове значення, або посилання на чарунку, що містить числове значення; формат — числовий формат із вкладки Число діалогового вікна Формат чарунок, відображуваного на екрані вибором команди Формат | Чарунки. Формат не може містити зірочку * і не може належати до категорії Загальний. Наприклад : ТЕКСТ(2.7153;   "0.000")  повертає 2.715 ЛІТЕРАТУРА Бухвалов А.В. и др. Финансовые вычисления для профессионалов.- СПб.: БХВ-Петербург, 2001.-320с. ил. Гарнаев А.Ю. Excel, VBA, Internet в экономике и финансах.- СПб.: БХВ-Петербург, 2001.- 816с.:ил. Евдокимов В.В. и др. Экономическая информатика. Учебник для вузов. Под ред. Д.э.н., проф. В.В.Евдокимова. – СПб.: Питер, 1997. – 592с. Згуровський М.З., Коваленко І.І., Міхайленко В.М. Вступ до комп’ютерних інформаційних технологій: Навч.посіб. – К.: Вид-во Європ. ун-ту (фінанси, інформ. системи, менеджм. і бізнес), 2000.- 265 с. Информатика. Базовый курс/ Симонович С.В. и др.- СПб.: Питер, 2000.- 640с.:ил. Карлберг, Конрад. Бизнес-анализ с помощью Excel.: Пер с англ.- К.: Диалектика, 1997.- 448с.: ил. Лук‘янова В.В. Комп‘ютерний аналіз даних: Посібник. – К.: Видавничий центр „Академія”, 2003. – 344с. (Альма-матер)

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *